Ask A Cartographer

points disappear

September 13 2010 | 4 comments
Categories: Publishing, Symbology

I use ArcGIS 9.1. I added parcel shapefile (polygon) and point feature in ArcMap. The problem is the more I zoom in, the more points disappear. What are the possible causes of this problem?

Thank you.

Mapping Center Answer:

I know this can be confusing -- you are actually seeing all the points in both displays but they are being drawn with the same size symbol even though the map is at different map scales. To see the point symbols (and in fact, at the same size oh all displays, you need to set what is called a "reference scale". This is a property of the data frame, so to set it, right click the data frame in the Table of Contents and on the General Tab, you can set the reference scale. You want to set this to be the map scale that is the same as what you want to use on the final map -- that way you can see what the symbology will look like when you publish it. An easy way to do this is to set that scale in ArcMap while you are in the page layout view, and then set the properties of the data frame -- that way you can 1) be sure the symbols look right at the final scale, and 2) use the Use Current Scale option when you set the reference scale.

Set reference scale and settings in shapefile, but posted by Christian Strachan on Aug 10 2011 3:41PM
I'm working with a point shapefile, and there are two specific features that disappear the more I zoom in. They seem to disappear at two different scales.

I've set a reference scale for the data frame, and also have the "Show Layer at all scales" setting turned on. I also tried turning it off at very high and low scales (above and below the scales I'm working at), and they still disappear.

Again, this is only happening for a couple of features - any idea where to start? Maybe exporting and importing into a new feature class?

Thanks.
Tech Support posted by Aileen Buckley on Aug 10 2011 6:31PM
Sounds like a problem that our Tech Support people should work with you on as it may be something specific to your data, map document, install of the software, etc... They can help you to trouble shoot this. Check the third tab of this page on Mapping Center for a link to contacting them.
Solved posted by Christian Strachan on Aug 13 2011 2:18PM
I exported the shape file data to a .gdb and used that data. That seemed to resolve the issue- I can now view the features at all scales.
Glad you are set! posted by Aileen Buckley on Aug 13 2011 5:59PM
Glad you found a solution. We'll log this in our "memory banks" in case anyone else runs into the same issue!

If you would like to post a comment, please login.

Contact Us | Legal | Privacy |