Ask A Cartographer

Delete Field Failed

April 17 2009 | 3 comments
Categories: Map Data

Once in a while (and more 3 out of 4 attempts right now), I try to delete a field or adding one, I got the message "Cannot get exclusive schema lock. Either being edited or in use by another application" when I use ArcToolbox or "Can not delete the select field from the selected table/feature class because it is use by another application/user" and I know for sure that it is not!

I re-started my computer and re-try to delete my field and still get the same message.

2 questions: why can't I modify my shapefile and how can I correct the situation?

Mapping Center Answer:

Locking on shapefiles is determined by the operating system.  There are no lock files like there might be with a personal geodatabase. 

So, if you cannot modify the file, one of two things is likely the culprit:

  1. There actually is a process using the data.  This could be you with a file browser, ArcGIS server, serving the data, or if the folder that contains the shapefile is shared, somebody else.
  2. The permissions of the file or folder are causing a the problem.  Check the Security tab of both the folder and file properties (right click on each in the Windows file browser).  The general tab of the file properties will tell you whether the file is Read-only, which can also be a problem (I'm looking at Window XP Professional, so you OS may be different).

Path length? posted by Fran├žois Turcotte-Goulet on Apr 17 2009 4:11PM
Could it be caused by the file and path names length?

A "virtual friend" redirected me to this thread: http://forums.esri.com/Thread.asp?c=93&f=988&t=254537

It says that there could be a limitation to the path length (128 char.), so I tested it.

My working folder path already had 120 char. So I created 2 shp, one with a short name (abc.shp for a total of 127 char.) and one with a long name (abcdefghijklmnopqr... .shp way longer that 128). I could add and delete field without problem I created to more shp with similar but shorter names (ab.shp and abcdefghijkl.shp) and then, I still could add and delete fields in abc and ab.shp but not in the two with the long names (they shared their first 128 characters).

I moved my four shapefiles in my C:\Temp directory and then, I could add and delete fields in all four. One of my colleague tested it too with the same result (we both have ArcView licences). My supervisor who have arcInfo never had any problem no matter where the features where...

Strange...
Moving folders worked for me. posted by Danielle Lee on Mar 16 2011 3:09PM
The 128 character issue seems to be the problem for me also. Pretty annoying moving Shapefiles just to add fields to calculate areas.
Pathname length posted by Aileen Buckley on Mar 31 2011 7:41PM
In ArcGIS 10.0 shapefiles use the same locking scheme used by the file geodatabase, so the forum answer is incorrect as far as the locking is concerned. The pathname plus the file name is limited to a total of 259 characters by Windows. There used to be a 128 character limit to pathnames in ArcView 3. But you are able to go up to the operating system limit in ArcMap/ArcCatalog. If you use a tool built with Python there may be other limits as Python has a maximum path length setting.

If you would like to post a comment, please login.

Contact Us | Legal | Privacy |